Your cart

Your Cart is Lonely

 

Select the problem you are experiencing:

Battery shows fully charged, but goes low after 10-15 minutes of use and/or unit run (very) slow.

Try the following:

  • Check riders weight & riding conditions, do not exceed the weight limit, go up a steep hill or attempt to tow objects. It is best to avoid these conditions at all times.
  • Check air pressure in front and rear tires, if pressure is low, inflate tires to recommended PSI (located on tire sidewall)
  • Check chain tension. If chain is too tight, refer to pg 9 in owner’s manual.
  • Check brake cable. If brake lever feels stiff when squeezed, then the cable is too tight. Squeeze brake lever firmly several times to loosen up the brake cable.
  • Make sure charger is plugged into charger port correctly & indicator lights are working properly. If the charger is not plugged into the charger port correctly, then make sure to plug charger into charger port correctly and charger for 8 hours (refer to page 3 in the Owner’s Manual.)
  • Secure the unit; turn power on & with NO weight on the unit, lift the back end up & apply the throttle. If the rear wheel spins freely, replace the battery.

Rear wheel barely moves.

Try the following:

  • Lift rear end up & manually spin rear wheel forward. Should spin 3-4 times with no resistance.
  • If wheel does not spin freely, replace the rear wheel.

By using our site, you acknowledge that you have read and understand our Privacy Policy, and our Terms of Service.

close